DNS issues on 2.2



  • Running pfsense 2.2 and I'm having issues with DNS.

    1. I first setup pfsense using these three DNS servers

    8.8.8.8
                                        8.8.4.4
                                        109.247.114.4

    2. On DHCP I've set no IP's on DNS and I though my clients was supposed to use pfsense and DNS.

    3. Problem is this is what they get as DNS via DHCP:

    DNS Servers . . . . . . . . . . . : 4fa1:9686::1
                                                192.168.10.1

    The second one is the ipv4 address of pfsense and works fine, but the first one is some ipv6 address that does not resolve causing all DNS lookups to be very slow since the first needs to time out before the clients goes on the the second.

    4. Tried to set the DNS servers explicitly on the DHCP page as. Now my clients gets this:

    DNS Servers . . . . . . . . . . . : 4fa1:9686::1
                                        192.168.10.1
                                        8.8.8.8
                                        8.8.4.4
                                        109.247.114.4

    Again the non-working ipv6 thing is at the beginnning. Where does this come from, and how can I remove it?



  • Why don't you turn off IPv6 if your ISP doesn't give you IPv6 and you have no IPv6 tunnels?



  • I have turned off IPv6 everywhere. A reboot of the client seems to have removed the ipv6 dns entry. I tried ipconfig /release and /renew before hand. But a reboot seems to have cleared it.


Log in to reply