Multi wan load balancing working need traffic from 1 pc to only use WAN2



  • Hi hope some one can help me ive searched these forums and come across some posts for similar requests but the answers dont seam to help me

    i have a multiwan setup with load balancing and fail over both of these work perfect

    Wan1 Virgin media 152/12
    WAN2 TalkTalk 65/20

    im happy for all other devices to use the load balancing as they currently do as its working very well, all except for one device that i want to exclusively use WAN2 for internet as it is a plex server and obviously better suited on the connection with the faster upload, having the computer being able to access 2 WANs is also causing havoc with plex accessing the outside world as well as plex sees the 2 IPs and they conflict,

    can some one give me a step by step how to do this, i thought it would be a case of using port forwarding and selecting WAN2 for the gateway and it would just automatically know to send port 32400 down only WAN2 but it dont work so obviously not that simple

    Thanks every so much

    Ash


  • LAYER 8 Netgate

    If your inbound 32400 translation is only on WAN2, then it can only be WAN2.  Reply-to should keep your return traffic going out the right interface.

    Not too familiar with plex but if you want connections started by the plex server outbound you need to add a rule on the LAN interface that takes traffic sourced from that IP address (or certain ports, or whatever) and sets the gateway to WAN2 instead of the gateway group.

    This needs to be above the more general rules.



  • thanks for the reply

    here's a few screen shots of what ive done im kinda new to this and have to say some of the stuff is really baffling when you just used to ISP router where in 2-3 clicks your ports are forwarded and work fine lol

    Firewall rule

    NAT

    Plex error

    Thanks Ash

    ![firewall rule.png](/public/imported_attachments/1/firewall rule.png)
    ![firewall rule.png_thumb](/public/imported_attachments/1/firewall rule.png_thumb)
    ![NAT port.png](/public/imported_attachments/1/NAT port.png)
    ![NAT port.png_thumb](/public/imported_attachments/1/NAT port.png_thumb)
    ![Screenshot 2015-03-24 22.49.43.png](/public/imported_attachments/1/Screenshot 2015-03-24 22.49.43.png)
    ![Screenshot 2015-03-24 22.49.43.png_thumb](/public/imported_attachments/1/Screenshot 2015-03-24 22.49.43.png_thumb)


  • LAYER 8 Netgate

    Why did you set a gateway on your associated NAT firewall rule?



  • do you mean in the Destination option as i say im new to all this if thats where you mean what should i be putting in there ?

    thanks Ash


  • LAYER 8 Netgate

    No.  In the automatically-generated firewall rule you edited it and set the gateway under advanced options to WAN2_GW.  Remove that.



  • ah right thanks done that, plex still cant access outside world thought, i have successfully managed to forward other stuff but they all goto wan1 which is set as the default dont know if that makes a diff, ive had a look at the settings and they are pretty much identical obviously except the ports/IPs but all the settings are the same, So its just very odd that plex is behaving like this literally its always worked perfect for me straight out of the box,
    It worked perfect in CLEAROS using the source rule to make all traffic from that system go via WAN2 but load balancing is very badly implemented in CLEAROS so id realy like to get things working as i think all round this is a much better OS for the job, just a lot more confusing for newbies lol

    Thanks again Ash

    EDIT

    right just discovered if i change WAN2 to be default plex starts working straight away and the stuff forwarded on WAN1 stop forwarding so i must have a setting some were wrong in the load balance set up ?


  • LAYER 8 Netgate

    The problem is in your rules on the LAN interface plex is on.  Post those.



  • here are my lan ones its just what i use for the loadbalancing

    Thanks Ash

    ![Screenshot 2015-03-25 00.06.18.png](/public/imported_attachments/1/Screenshot 2015-03-25 00.06.18.png)
    ![Screenshot 2015-03-25 00.06.18.png_thumb](/public/imported_attachments/1/Screenshot 2015-03-25 00.06.18.png_thumb)


  • LAYER 8 Netgate

    Right.  Above the LB rule you need one that sends connections from plex to just WAN2.  I don't know how you would define "traffic from plex" either just the source IP address of the plex server, or maybe the source IP address and a subset of source ports.

    You do know the 3rd and 4th rules will never be processed right?



  • @ash45:

    i have a multiwan setup with load balancing and fail over both of these work perfect

    But not really needed, because if one of the WAN interfaces is dying or fails the entire traffic
    is routed through the other WAN interface, so you got fail over on top by using load balancing.

    And there are three main possibilities to load balance.

    • session based load balancing
    • service based load balancing
    • policy based routing

    So that would be enough to solve the problem, or?


Log in to reply