[SOLVED] Mysterious failover WAN DNS problem



  • Hi all, really enjoying pfSense!

    I have two connections set up. The main WAN is normal DHCP from modem and WAN 2 is a PPoE connection to another modem. I've set up a gateway group and verified both connections are working by swapping round the tiers in the gateway group. pfSense uses whichever connection is Tier 1 and it works great.

    The problem arises when the main WAN (Tier 1) goes down. pfSense uses the Tier 2 WAN2 connection as expected but there seems to be no DNS servers available to clients. I have specified DNS servers for the Tier 2 connection in the general configuration and have tried all combinations of "Allow DNS server list to be overridden by DHCP/PPP on WAN" and specifying DNS servers for both WANs.

    It seems that the Tier 2 (WAN2) connection only uses its own DNS servers when WAN1 is up and as soon as it goes down WAN2's DNS stop working.

    I'm stumped! Thanks in advance.



  • After much tinkering all it took was to "Enable Forwarding Mode" under DNS Query Forwarding in the DNS Resolver settings.


Log in to reply