Cannot get unbounded Host Override working



  • Hi, running 2.2.6-RELEASE and DNS Resolver and just trying to do a host override for my NAS 192.168.1.5

    DNS resolver is enabled, all interfaces, DNSSEC enabled, forwarding mode off and the other basic dns settings not enabled. Iv replaced names with example data but the subdomain depth and any special characters (is -) are included. The real TLD is .nyc

    I set a host over ride:
    host: DiskStation-ME
    domain: example.me.nyc
    ip: 192.168.1.5

    Host override has no effect and OSX 10.11.3 returns the A record that is the real one hosted by Route 53.
    My mac is set to only use the local pfsense 192.168.1.1 as DNS.

    I confirmed mac is using pf sense with host -a example.me.nyc
    I get the AWS name servers as the authoritative and the A record from Route 53 though it resolved via pfsense as last line reads Received 191 bytes from 192.168.1.1#53 in 406 ms

    I can achieve what I want via the DNS resolver advanced settings by adding:
    server:
    local-data: "example.me.nyc A 192.168.1.5"

    However this is exactly what host override is for so not sure what up. Only thing I can think is I am setting host wrong in the override settings but from what I under stand does it even matter what you put there? What I am putting is the set host name on the NAS and is also what OSX returns when I do host 192.168.1.5 (without the Domain part) ie host returns Domain name pointer DiskStation-ME.example.me.nyc.

    First post and excited to join the community
    Thanks


  • LAYER 8 Global Moderator

    Do did you do a query to unbound and validate your override works or doesnt work.. simple nslookup or dig, or drill or host or whatever your fav dns tool is..

    Do you want your name to be diskstation or example?  in your first example your fqdn would be diskstation-me.example.me.nyc

    In your advanced your host is example and the domain is me.nyc

    See attached.. Host overrides work correctly.. lets see your host override, you sure you put in resolver section and not forwarder section.. Need to make sure you put them in the right place for the service your using.




  • Ok thanks, so I was misunderstanding the host field.
    If I put example for host and then leave domain as example.me.nyc then it looks like it works as I desired such that DNS clients will resolve example.me.nyc to 192.168.1.5


  • LAYER 8 Global Moderator

    What would you think it was???

    "Name of the host, without domain part"

    seems pretty straight forward to me..



  • I wasn't familiar with the far left part being considered the host part, I always just thought of it as a sub domain in an A record. I was thinking in terms of I want this real A record consisting of a TLD, a second level domain, and a subdomain to actually resolve to this private address when accessed from this network.

    Entering it like you would on most DNS UIs, ie Route 53 and Cloud Flare etc and more along the lines of how you input it in the advanced settings part here or in a hosts file, makes more sense to me but calling it host seems to be correct as well so was my fault for not knowing that.

    I think I was further confused bc the 'host' part of the real A record, doesn't really make sense to be the general hostname / the general name I would refer to the local server that I was overriding it to, but that was just a situational quirk on my end.

    Thanks for your help


  • LAYER 8 Global Moderator

    so which part in a fqdn did you think was the host??  you have www.domain.com that points to a server and www is a subdomain?

    in many dns ui your working with 1 domain so all you have to enter is the host.  With an override you could be using any domain google.com neowin.net, etc..  You own multiple domains and need them all to point to your private IPs, etc.

    glad you got it sorted.


Log in to reply