Whats App lento no E2Guardian



  • Fala meu povo! Tudo bem com vocês? Espero que sim

    Eu estou usando o pfsense 2.4.4-p3 + E2Guardian, onde só faço o bloqueio de umas poucas categorias. Porn, Spyware, etc.

    O que está acontecendo e não estou entendendo o motivo, é o Whats App ficar "travado" de vez em quando, ele fica procurando mensagens como se estivesse tentando conectar ao servidor, mas também quando conecta fica de boa por um tempo. Já tentei colocar ele no by bass, mas não fez diferença. Se desabilito o E2G, ele conecta instantaneamente.

    Alguém passou por isso e achou uma solução, ou tem alguma sugestão do que pode ser feito?

    Obrigado!



  • Bom dia amigo, blz? Vc chegou a criar um alias para o Whatsapp e liberar o trafego para este? Ou vc quer liberar apenas texto e bloquear imagens/videos ?



  • Boa tarde @ghislenidroid cheguei a criar um alias com os endereços whatsapp.net e whatsapp.com e colocado no by pass.

    Minha intenção é deixar ele todo liberado. E ele funciona todas as funções normalmente, mensagens, vídeos, imagens, chamadas. O problema é que que ele tipo "desconecta" do servidor e fica um tempo procurando mensagens. Ai depois de um certo tempo, as vezes uns poucos segundos, as vezes vários segundos ele "conecta" novamente, ai volta ao funcionamento normal. Ai fica nesse vai e vem sem causa aparente.



  • @obmor aqui eu tenho um Alias com este conteúdo e funciona.

    AS11917	
    66.111.49.0/24
    66.111.48.0/24
    66.111.48.0/22
    2620:13e:100f::/48
    2620:13e:100e::/48
    2620:13e:1000::/44
    

    Confere e reporta se der certo.

    Abraço



  • @ghislenidroid said in Whats App lento no E2Guardian:

    66.111.48.0/22

    Bom dia @ghislenidroid feita a configuração, agora ver como se comporta. Já observei um momento em que deu a demora na conexão, como mencionado antes, mas até agora só observei uma vez.



  • Olá @ghislenidroid

    Teste feito e continua da mesma forma... :/

    De momentos em momentos, ele passa um tempo só procurando mensagens e vendo se vai enviar ou não as mensagens que estão só com o relógio, como se tivesse esperando internet. Ai só desabilitar o E2G e funciona normal.



  • Olá @obmor

    Você está usando o E2Guardian em modo transparente e com interceptação SSL?

    Atenciosamente.

    César Moura



  • Estou sim @acamoura



  • @obmor resolvi esse problema de lentidão realizando os seguintes procedimentos:

    Primeiramente criei um alias para as redes (cidr) do whatsapp que realizei o levantamento das redes do mesmo conforme arquivo em anexo para você importar para criação do seu alias.

    cidr_whatsapp.txt

    Segundo passo criei um alias para endereços (urls) do whatsapp que realizei o levantamento conforme arquivo em anexo para você importar para a criação do seu alias.

    urls_whatsapp.txt

    Terceiro passo:

    Clique em Services --> E2Guardian Proxy --> Daemon --> Na opção Bypass Proxy for These Destination IPs coloque os 2 aliases que criou separados por ; e aplique as configurações.

    Atenciosamente.

    César Moura



  • Obrigado pela resposta @acamoura
    Tirei o pfsense da empresa para instalar no novo prédio para o qual estamos mudando. Assim que possível irei fazer esse procedimento e retorno com o resultado!



  • tem liberar as portas no firewall. nesse site mostra algumas portas. outras você vai ter que fazer teste. olha na aba, Status/Logs do sistema/Firewall/Visão Dinâmica. faça um filtro avançado e coloca somente o ip do seu celular para testes, e verificas portas de bloqueio.
    site para auxilio.
    https://developers.facebook.com/docs/whatsapp/guides/network-requirements/?locale=pt_BR

    as portas que liberei foi
    5222, 5223, 5228, 3478
    nao sei de cor mais uma e para ligação outra para video chamado outra para foto video.



  • Olá @rogeriocss

    Obrigado pela resposta, essas portas já estão liberadas. Sem a regra liberando elas o Whats App faz é não funcionar mesmo, mesmo sem o E2Guardian. rsrs.. Irei conferir os endereços do link juntamente com os fornecidos com o do amigo @acamoura no post anterior dele.

    Infelizmente a empresa está em mudança e estou tendo que resolver muita coisa, ai não estou conseguindo tempo para fazer essas configurações e colocar pra testar, mas assim que possível darei um retorno a vocês.



  • Bom dia. EU notei que esse problema acontece somente em aparelhos android.
    Com Iphones roda 100% liso. Se a pessoa esta com whats aberto, e ela desconecta da wifi e conecta novamente o whats não volta a funcionar na hora, demora a enviar mensagens etc. Se vc encerra a aplicação e abre de novo, o whats volta normal.
    Parei o E2 e funciona normalmente depois.


Log in to reply