[SOLVED] Certain Websites won't load when connecting behind Pfsense



  • I have DSL internet connection going into my Pfsense network gateway (DNS, DHCP, NAT etc).

    The following websites will not load when I try to connect from behind Pfsense:
    http://schemas.xmlsoap.org/soap/encoding/
    http://www.drupal.org
    http://api.drupal.org
    http://www.dailycamera.com

    If I remove Pfsense from the network, and connect directly though the modem, the sites all load fine.

    Any ideas on what could be wrong or where I should start looking in Pfsense to debug?

    I have a fairly default install of pfsense running. I do not have traffic shaping enabled, just NAT.

    Thanks
    Jon



  • I found the problem is actually a Firware bug in the Actiontech M1000 Qwest DSL Modem. Here is what fixed the problem for me:

    1. Disable the DMZ setup for my PFsense computer in the DSL modem's advanced configuration
    2. Click the firewall settings… make sure everything is set to default... if so, do not change anything... click apply.

    After these steps all websites are accessible through my Pfsense gateway connected to the Qwest DSL modem.



  • you need to change from ppoa to ppoe in the modem OR enable bridging and have pf be the router.

    Qwest tech had me do the ppoa -> ppoe and it worked, i then enabled bridging and have been problem free ever since.

    its not just the sites you listed, it varies, mine were opendns and frys electronics, to name a few, qwest says its glitch that happens sometimes….


Log in to reply