Installation help required



  • I have been trying to install pfsense now for 2 days, I have burnt 2 cd images but still cant get it to load. Each time its hanging on

    GEOM_LABEL and completely locking up to the extend you have to reset the PC

    Does anyone have a suggestion



  • Yeah, post details of the version of pfSense you're trying to install, what hardware you're using and what type of CD-ROM you're trying to install from.



  • The unit is a
    MSI K8T Neo2-F Mainboard with the following

    BIOS
      • The mainboard BIOS provides "Plug & Play" BIOS which detects the peripheral devices and expansion cards of the board automatically. 
    • The mainboard provides a Desktop Management Interface (DMI) function which records your mainboard specifications.

    On-Board IDE 
      • An IDE controller on the VT8237 chipset provides IDE HDD/CD-ROM with PIO, Bus Master and Ultra DMA 66/100/133 operation modes. It can connect 4 Ultra ATA drives. 
    • Serial ATA/150 controller integrated in VT8237

    • Up to 150MB/s transfer speed
    • Can connect up to 2 Serial ATA drives
    • Support RAID 0, RAID 1

    Audio
      • 8 Channel software audio codec Realtek ALC850
    • Compliance with AC97' v2.3 Spec 
    • Meet PC2001 audio performance requirement 
    • Provide onboard SPDIF out

    Network
      • Realtek 8110S Dual layout 
    • Integrated Gigabit Ethernet MAC and PHY transceiver, auto-negotiation operation. 
    • Supports single-port 10MB/s, 100MB/s, 1000MB/s Base-T application. 
    • Compliance with PCIv2.2 and LAN on Motherboard (LOM) standard.

    On-Board Peripherals
      - 1 floppy port supports 1 FDD with 360K, 720K, 1.2M, 1.44M and 2.88Mbytes

    • 1 serial ports COM1
    • 1 parallel port supports SPP/EPP/ECP mode
    • 8 USB 2.0 ports (Rear x 4 / Front x 4)
    • 5 audio ports in vertical (Left, Center, Right, Line-in, MIC)
    • 1 SPDIF out
    • 1 RJ-45 jack 
      -  1 IrDA connector for SIR/ASKIR/HPSIR

    The processor is AMD 64 4000+

    Its pfSense v1.2 downloaded from http://www.pfsense.org/mirror.php?section=downloads

    Burnt onto a Datasafe CDR one at 48x the second at 16x but still have the same outcome and hang in the same spot.



  • What type of HD do you have connected (PATA or SATA), what type of CD-ROM drive are you using to install from, what other hardware do you have installed?



  • Its a standard IDE HDD and a DVD Combo drive, all the above are onboard devices. I also have an nVidia video card and 3 realtek lan cards





  • I agree with havoc about reading.  I am not familiar with that error as all my installs worked pretty much flawlessly.  Although I haven't used anything as new as you are trying.  I've used from p2's up to p4's though with no problem.  Intel cards work the best , and I've used 3com and several netgears.  Your problem sounds like a hard drive issue.  Are you trying to set specific parameters? I just use default.  Maybe try another hard drive.  Good luck.



  • There isn't a floppy and its switch off in the Bios, the Bios is the latest version



  • Did you read and follow that guide?  It's also worth disabling ACPI to see if that's the problem.



  • generally when you see a freeze at that point it's ACPI. See the boot troubleshooting page previously linked.



  • I have followed the suggestions, as previously stated I have no fdd and have also disabled ACPI in the bios but it still locks up in the same place



  • I suspect that you are using pfSense 1.2 thats based on FreeBSD 6.2. You may have more success with the pfSense kit that based on FreeBSD 6.3. This kit can be downloaded from http://cvs.pfsense.org/~sullrich/testing_images/6/FreeBSD_RELENG_6_3/pfSense_RELENG_1_2/

    Alternatively you could try one of the 1.2.1-BETA snapshot images - see the 6th July 2008 announcement of the availability of pfsense 1.2.1 snapshots for a link to  the location of the builds. The announcement is in http://blog.pfsense.org/?p=207



  • I had this issue yesterday during an install.
    Went away and came back 20 mins later and it had continued onto a successful install.
    Wrote to HDD and all subsequent reboots go straight through.



  • Tried your suggestion. Left it 2 hours but still the same.

    Reading between the lines I could need to

    Change mobo
    Change HDD
    Change CDRom
    Change Leads
    Change whatever else!!!!!

    Whats the point



  • @di66er:

    I have followed the suggestions, as previously stated I have no fdd and have also disabled ACPI in the bios but it still locks up in the same place

    Hey di66er, I had a similar problem a while ago. BIOS/ACPI wasn't playing nice with FreeBSD, and fiddling with BIOS wasn't helping. On the FreeBSD boot menu (something like 8-9 choices?), you have only a few seconds to hit a key to override the default. Hit one of the arrow keys to stop the timer, then choose the option to disable ACPI kernel. Hopefully that'll work for you!



  • Tried that but stiil hangs on GEO_LABEL

    Could this have something to do with the system being 64bit



  • Have you tried one of the 1.2.1 BETA testing images?

    I can't see how 64 bits would be an issue: the 64-bit capable CPUs also execute the 32-bit instructions and pfSense is 32-bit software.



  • At this point I can say I think I have tried every distro of pfsense.

    I have disks everywhere



  • Those are good ideas, 1.2 release seems real stable and works on everything I throw it on…if you still have problems, maybe try another HDD and make sure to disable ACPI.  I have disabled ACPI on all my installs with no issues.



  • I had an old 8 gig hdd so tired that also tried different distros but still hanging at same place



  • You said you disabled ACPI in the BIOS, but have you disabled it at the boot prompt when the CD starts to boot?



  • Yes



  • I have tried again today to get pfsense set up and am still having the same problems. I have been back into the bios and disabled everything except the essentials, I have also started the set up with option 2 ACPI disabled but still hangs at GEO_LABEL. I have downloaded the suggested distro from the link but its still the same.

    From the suggestions I have received I can see the only way forward it a trial and error revamp of the system which is out of the question. I may as well buy a quan wan router as it would be cheaper.

    I would like to thank everyone who has contributed to this thread and although it hasn't help me your suggestions may have helped others.



  • Do you have access to another computer?

    Here's a procedure I have used. I booted the CD and installed to a USB drive (a 2.5inch notebook drive in a USB caddy) which I then connected to the computer on which I actually wanted to run pfSense. I had to configure the BIOS to boot off a "USB Hard Disk" and now it works fine. This sort of thing may get you past the "CD problem". Once you have the software installed you probably won't need to use the CD again for a good while.)

    There are a number of variants, for example:

    • install to a hard drive on the other computer then move the hard drive to the computer on which you had the trouble.

    • install to a USB flash drive, take it to the real target computer, boot it then copy (dd) the USB flash drive to the hard drive on the target computer


Log in to reply